Languages & Coding > SmallBASIC

Missing libraries libm.so.6 libpng16.so.16

(1/1)

Ivan:
After running
SmallBASIC-FLTK_12.23-x86_64.AppImage
I got an error
./SmallBASIC-FLTK_12.23-x86_64.AppImage: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by ./SmallBASIC-FLTK_12.23-x86_64.AppImage)
./SmallBASIC-FLTK_12.23-x86_64.AppImage: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /tmp/.mount_SmallBD3s49V/usr/bin/../lib/libpng16.so.16)

(64-bit MX Linux / Debian based)

==
sudo apt-get install libpng16-16
replies that the newest version of libpng16-16 is already installed
(1.6.36-6)

chrisws:

--- Quote from: Ivan on September 04, 2021, 07:21:14 ---After running
SmallBASIC-FLTK_12.23-x86_64.AppImage
I got an error
./SmallBASIC-FLTK_12.23-x86_64.AppImage: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by ./SmallBASIC-FLTK_12.23-x86_64.AppImage)
./SmallBASIC-FLTK_12.23-x86_64.AppImage: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /tmp/.mount_SmallBD3s49V/usr/bin/../lib/libpng16.so.16)

(64-bit MX Linux / Debian based)

==
sudo apt-get install libpng16-16
replies that the newest version of libpng16-16 is already installed
(1.6.36-6)

--- End quote ---

Thanks for reporting this. I think I can solve it by building the FLTK library slightly differently.

How did you go with the SDL version?

Derron:
Just build it on Ubuntu 18 - or maybe even older. Ubuntu 20+ has too new glibc versions.


bye
Ron

chrisws:

--- Quote from: Derron on September 05, 2021, 13:00:46 ---Just build it on Ubuntu 18 - or maybe even older. Ubuntu 20+ has too new glibc versions.


bye
Ron

--- End quote ---

Fixed!

Thanks everyone for your help.

I've rebuilt the AppImages with Ubuntu 18 and have added these to the release.

Navigation

[0] Message Index

Go to full version