October 25, 2021, 18:32:19

Author Topic: Missing libraries libm.so.6 libpng16.so.16  (Read 531 times)

Offline Ivan

  • Jr. Member
  • **
  • Posts: 1
Missing libraries libm.so.6 libpng16.so.16
« on: September 04, 2021, 07:21:14 »
After running
SmallBASIC-FLTK_12.23-x86_64.AppImage
I got an error
./SmallBASIC-FLTK_12.23-x86_64.AppImage: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by ./SmallBASIC-FLTK_12.23-x86_64.AppImage)
./SmallBASIC-FLTK_12.23-x86_64.AppImage: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /tmp/.mount_SmallBD3s49V/usr/bin/../lib/libpng16.so.16)

(64-bit MX Linux / Debian based)

==
sudo apt-get install libpng16-16
replies that the newest version of libpng16-16 is already installed
(1.6.36-6)
« Last Edit: September 04, 2021, 07:31:43 by Ivan »

Offline chrisws

  • Full Member
  • ***
  • Posts: 117
    • SmallBASIC
Re: Missing libraries libm.so.6 libpng16.so.16
« Reply #1 on: September 05, 2021, 10:51:19 »
After running
SmallBASIC-FLTK_12.23-x86_64.AppImage
I got an error
./SmallBASIC-FLTK_12.23-x86_64.AppImage: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by ./SmallBASIC-FLTK_12.23-x86_64.AppImage)
./SmallBASIC-FLTK_12.23-x86_64.AppImage: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /tmp/.mount_SmallBD3s49V/usr/bin/../lib/libpng16.so.16)

(64-bit MX Linux / Debian based)

==
sudo apt-get install libpng16-16
replies that the newest version of libpng16-16 is already installed
(1.6.36-6)

Thanks for reporting this. I think I can solve it by building the FLTK library slightly differently.

How did you go with the SDL version?

Online Derron

  • Hero Member
  • *****
  • Posts: 3674
Re: Missing libraries libm.so.6 libpng16.so.16
« Reply #2 on: September 05, 2021, 13:00:46 »
Just build it on Ubuntu 18 - or maybe even older. Ubuntu 20+ has too new glibc versions.


bye
Ron

Offline chrisws

  • Full Member
  • ***
  • Posts: 117
    • SmallBASIC
Re: Missing libraries libm.so.6 libpng16.so.16
« Reply #3 on: September 07, 2021, 21:31:31 »
Just build it on Ubuntu 18 - or maybe even older. Ubuntu 20+ has too new glibc versions.


bye
Ron

Fixed!

Thanks everyone for your help.

I've rebuilt the AppImages with Ubuntu 18 and have added these to the release.


 

SimplePortal 2.3.6 © 2008-2014, SimplePortal