April 10, 2020, 06:00:48 AM

Author Topic: Memory accmulation problem in blitzmax  (Read 1070 times)

Offline Steve Elliott

  • Hero Member
  • *****
  • Posts: 2311
  • elgol developer
Re: Memory accmulation problem in blitzmax
« Reply #15 on: October 30, 2019, 07:49:40 PM »
Glad you found the bug.  Coding can be very rewarding, but also sometimes very frustrating.  :-\
Windows 10, 64-bit, 16Gb RAM, CPU Intel i5, 3.2 GHz, Nvidia GeForce GTX 1050 (2Gb).
MacOS Catalina, 64-bit, 8Gb RAM, CPU Intel i5, 2.3 Ghz, Intel Iris Plus Graphics 640 1536 MB.
Linux Mint 19.3, 64-bit, 16Gb RAM, CPU Intel i5, 3.2 GHz, Nvidia GeForce GTX 1050 (2Gb).

Offline Hardcoal

  • Sr. Member
  • ****
  • Posts: 409
Re: Memory accmulation problem in blitzmax
« Reply #16 on: November 18, 2019, 05:50:23 PM »
Memory accumulation is back!   ::)

This things are hard to trace... 

This time its weirder.. but smaller
it has weird laws..
when i got 2 objects its ok. when i got 3 objects and above its starting to accumulate..

since my project is ultra complex.. (ye .. ultra) its not an easy task to trace..

and Stupid Blide IDE doesnt let you go back in code.. which makes it even harder..

Just updating


Happy New Year

Offline Hardcoal

  • Sr. Member
  • ****
  • Posts: 409
Re: Memory accmulation problem in blitzmax
« Reply #17 on: November 18, 2019, 07:00:45 PM »
I just solved the problem..
I dont even have a clue what exactly was wrong. I just turned off something and it worked..
hopefully it will continue being so!

This was a major problem, not a tiny bug that i can deal with in minutes.. so im glad its behind me. with gods will, hopefully not to see it no more.
Happy New Year

 

SimplePortal 2.3.6 © 2008-2014, SimplePortal