December 13, 2019, 05:06:43 PM

Author Topic: I've built a recent version of BlitzMaxNG for Raspberry Pi  (Read 417 times)

Offline NoNameHere

  • Jr. Member
  • **
  • Posts: 9
I've built a recent version of BlitzMaxNG for Raspberry Pi
« on: October 04, 2019, 03:30:50 PM »
The official build of BMX-NG for RPi is quite outdated, and it doesn't have (and is not able to compile) xml.mod, something that I needed.

Thus, I've decided to embark on an adventure of building a modern version of NG starting with a version from 2016. I had to go through a bunch of intermediate versions, but got there in the end.

Thought it may be useful, so I'd share it: https://drive.google.com/file/d/11WxssvHDa-MoH39jMHNYUNY4BT46O4eE/view?usp=drivesdk

This version was built with latest revisions of bcc, bmk, pub.mod and brl.mod as of 23rd September 2019.

The maxide is still the old one from 2016, so are the makedocs and docmods. Also note that core.bmk and make.bmk haven't been updated either -- still seems to work fine, though.

Only brl.mod and pub.mod are included.

There's one problem with maxide: its config file needs to be set to read only, otherwise it writes something into there that causes it to crash on next launch. (May be a problem unique to my installation -- it's raspbian-nspawn-64, not an official raspbian)

Binaries compiled with this version still run fine within the Linux Deploy container on Android devices, too.

Offline Kippykip

  • Full Member
  • ***
  • Posts: 111
    • Kippykip Forums!
Re: I've built a recent version of BlitzMaxNG for Raspberry Pi
« Reply #1 on: October 04, 2019, 04:46:06 PM »
Woah man! Nice!
YOu gonna put a release on github or anything?

Offline Derron

  • Hero Member
  • *****
  • Posts: 2614
Re: I've built a recent version of BlitzMaxNG for Raspberry Pi
« Reply #2 on: October 04, 2019, 10:15:01 PM »
MaxIDE ... update it and that ini file problem should be gone.


@ xml.mod
I assume you mean libxml.mod ? It should work with the more current versions.
For simple stuff there is brl.mod/mxml.mod now. Useful if you do not need xslt support or similar advanced stuff. I upgraded my code from libxml to mxml basement without much trouble.


If there are problems with a provided module and RPi you surely planned to raise an issue - didn't you?


bye
Ron

Offline NoNameHere

  • Jr. Member
  • **
  • Posts: 9
Re: I've built a recent version of BlitzMaxNG for Raspberry Pi
« Reply #3 on: October 05, 2019, 01:52:26 AM »
Kippykip, you mean the Brucey's bmx-ng repository? That's up to Brucey, but I think a full recompile should be made, with new maxide and everything, for an official release. This here is just a quick and dirty unofficial build.

Derron, I'm using brl.xml. I wasn't actually aware that libxml.mod exists (Just googled it now).

I did try to get brl.xml working on the outdated official version of RPi BlitzMax, but the older bcc didn't support method overloading and wasn't able to compile it, which started the whole adventure of getting the newer version of the compiler onto the RPi.

Offline Derron

  • Hero Member
  • *****
  • Posts: 2614
Re: I've built a recent version of BlitzMaxNG for Raspberry Pi
« Reply #4 on: October 05, 2019, 11:03:14 AM »
brl.xml uses pub.mxml.
I proposed such a lightweight basic xml module a while ago and Brucey brought it to NG. Think nowerdays people should not hunt for 3rd party modules for basic stuff like json/xml support.

If stuff does not compile on recent RPI:
- open an issue on github.com/bmx-ng/bmx-ng so Brucey can "track" it / becomes aware

If you want to try on your own: try to compile newer BMK with your current installation, then you will have to do some "inbetween" updates as newer BCC requires newer BRL - and newest BRL requires newer BCC ;). So you need to find some sweetspots which work.
Or as said above: raise an issue and I am sure Brucey will try to pack something together. I will also directly inform him about the issue now - so maybe he will read it the next days.


bye
Ron