June 27, 2019, 12:21:25 PM

Author Topic: Problem compiling OpenB3D  (Read 2311 times)

Offline Krischan

  • Full Member
  • ***
  • Posts: 197
    • Krischan's Homepage
Re: Problem compiling OpenB3D
« Reply #15 on: October 23, 2017, 07:09:21 PM »
Ahh the Task Manager, I forgot - thanks!

And Henry, I've already used the files from the link you've posted, see Point 34. Downloading them again results in the same error, see freeprocess.bmx in the bmx-ng repository, it is Strict there, too. My current setup is a BlitzMaxOS folder at C:\Apps\BlitzMax and a BlitzMaxNG folder at C:\Apps\BlitzMaxNG with MinGW 5.1.0.2 located at C:\Apps\BlitzMax\MinGW and I think this one is used by the NG bmk to compile the modules, is that correct for NG?

Here are my two folders I've zipped and backup during the steps 1-37 to play with: BlitzMax (until step 23) and BlitzMaxNG (until step 37)

But Derrons suggestion sound good. So Henry (or anybody else), do you have a *working* version with brl and pub mods of the latest repository that you could upload somewhere? I could try then to compile it on my own system. IMHO Github is nice for development but we really could need some kind of installer for Windows to run a reliable version out of the box, as a beginner is totally lost with this setup procedure. And I start feeling like a beginner, even though I should not be one.
Kind regards
Krischan

Windows 10 Pro | i7 9700K@ 3.6GHz | RTX 2080 8GB]
My Blitzbasic Archive | Extrasolar Project | My Github projects

Offline Henri

  • Full Member
  • ***
  • Posts: 201
Re: Problem compiling OpenB3D
« Reply #16 on: October 23, 2017, 08:06:24 PM »
I downloaded BlitzmaxNG from your link and copied the folder in C:\BlitzmaxNG. I then copied MaxIDE from my folder just because I'm used to compile modules within IDE (it's also a way to check if MinGW is seen correctly, but not super important here).

Upon selecting 'Rebuild all modules' it went fine until I hit the barrier you mentioned:

Quote
[ 89%] Processing:freeprocess.bmx
Compile Error: Overriding method does not match any overridden method. (Detail: Return type is "Int", expected "Void". You may have Strict type overriding SuperStrict type.)
[C:/BlitzMaxNG/mod/pub.mod/freeprocess.mod/freeprocess.bmx;56;0]
Build Error: failed to compile (-1) C:/BlitzMaxNG/mod/pub.mod/freeprocess.mod/freeprocess.bmx
Process complete

Next I made a backup of the freeprocess.bmx file in ..\mod\pub.mod\freeprocess.mod just to be safe, and opened the file in notepad. I then copied the version I posted previously and pasted it into freeprocess.bmx overriding everything (and remembering to save) to end up with Superstrict version of the file.

After trying to recompile again, everything went fine this time with no errors at compile time.

I agree that this whole process could be little more user friendly, so I'll try make a ready to download version.

-Henri
- Got 01100011 problems, but the bit ain't 00000001

Offline Flanker

  • Jr. Member
  • **
  • Posts: 39
    • Youtube channel on Blitzmax programming prototypes
Re: Problem compiling OpenB3D
« Reply #17 on: November 02, 2017, 11:05:03 PM »
Instead of creating a new post I use this one. I tried to install the last version of OpenB3D by markcwm but it resulted in a compilation error, "Unable to convert from Byte array to Int array", line 570 in the file "openb3d.mod\inc\T3DS.bmx".

I just modified this line 570 :
Code: [Select]
Local col:Byte[] = [255, 255, 255]
By this :
Code: [Select]
Local col:Byte[] = [Byte(255), Byte(255), Byte(255)]
And so far it works fine. I'm using vanilla blitzmax 1.50, and GCC 4.7.1-2 using the batch file from Brucey.
Everyone knew it was impossible, until someone who didn't know made it.