Ooops
May 27, 2022, 03:28:26

Author Topic: Libcurl and old BlitzMax 1.50?  (Read 632 times)

Offline Midimaster

  • Hero Member
  • *****
  • Posts: 638
    • Midimaster Music Education Software
Libcurl and old BlitzMax 1.50?
« on: February 08, 2021, 09:34:19 »
Hello, I'm trying to modify a very big old Bmax project to enable https-connections. Therefore I want to know if it is possible to use the LibCurl-Module I found here...
https://github.com/maxmods/bah.mod/tree/master/libcurl.mod
... also for my old Bmax 1.50?

Do I need any modification or can I easily copy the content to my "C:\BlitzMax\mod\BaH.mod" folder ?

Do I need any steps before I can use it?
...back from africa

Offline Derron

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3886
Re: Libcurl and old BlitzMax 1.50?
« Reply #1 on: February 08, 2021, 10:14:22 »
I did not check it out - but "maxmods" should work with "vanilla". Only the stuff directly in "bmx-ng" is "ng only".

Yet it might happen that they (maxmods) get updated and Brucey only cross checked with NG.


So... just try it out and report back the issues you experienced (especially compiler-errors). Also do not forget: with vanilla you are bound to some more specific MinGW versions - so ensure to use whatever has to be used.


Another possibility: move on to NG (if doable - or if your framework is encapsulated and could be "upgraded" separately - so your other projects benefit from it too).


bye
Ron

Offline Grisu

  • Jr. Member
  • **
  • Posts: 48
    • Pocket Radio Player
Re: Libcurl and old BlitzMax 1.50?
« Reply #2 on: May 12, 2022, 12:43:39 »
Hi,

I'm still using Libcurl for my PRP app, coded in more or less Vanilla BMX. 

For most cases you only need to copy the fulll mod dir over. Then rebuild "all modules".
LibCurl got very bloated after a certain point (like adding more like 1 MB to simple exe files).

Grisu

P.S.
If you are in need, I can send you "Version: 1.05" of the mod (2016). Which should have the best compatibilty (runs fine with up to GCC 12.1).
Sadly, BMX NG breaks all kinds of stuff, if you use other than Brucey's mods.




Pocket Radio Player     Cardwar

Offline Midimaster

  • Hero Member
  • *****
  • Posts: 638
    • Midimaster Music Education Software
Re: Libcurl and old BlitzMax 1.50?
« Reply #3 on: May 12, 2022, 18:00:08 »
Thanks, but my question is one year ago. Meanwhile I changed to BlitzMax NG, where all works perfect
...back from africa

Offline LT

  • Jr. Member
  • **
  • Posts: 37
Re: Libcurl and old BlitzMax 1.50?
« Reply #4 on: May 17, 2022, 00:56:33 »
If you are in need, I can send you "Version: 1.05" of the mod (2016). Which should have the best compatibilty (runs fine with up to GCC 12.1).
Sadly, BMX NG breaks all kinds of stuff, if you use other than Brucey's mods.

Hi, I was attempting to use LibCurl just recently and it doesn't work with "https" at all, afaik.  My version is 1.04 and works with Vanilla BMax, which is what I use.  Does 1.05 work with "https"?
« Last Edit: May 17, 2022, 06:21:19 by LT »

 

SimplePortal 2.3.6 © 2008-2014, SimplePortal