October 19, 2021, 01:27:01

Author Topic: BaH.libcurl.mod and BlitzMax NG  (Read 308 times)

Offline Midimaster

  • Sr. Member
  • ****
  • Posts: 363
    • Midimaster Music Education Software
BaH.libcurl.mod and BlitzMax NG
« on: February 13, 2021, 07:57:34 »
It looks like the Bah.libcurl.mod should be revised... Here my report of adding it to BlitzMax NG. Perhaps it will help future people to get it started more comfortable:

1. Bah.libcurl.mod needs some other modules. But there is no ReadMe to inform about that. So you additional need to copy Bah.libssh2.mod and Bah.mbedtls.mod to the BlitzMax.mod.Bah-Folder.

2. Some examples are not longer working. Somebody should update them:

Example 2
Code: BlitzMax
  1. curl.setProgressCallback(progressCallback) ' set the progress callback function
fails with the error message:
Code: [Select]
Compile Error: Unable to convert from Int(Object,Double,Double,Double,Double) to Int(Object,Long,Long,Long,Long).


Example 3
Code: BlitzMax
  1. curl.setOptString(CURLOPT_URL, "ftp.sunsite.dk/pub/")
fails with the error message:
Code: [Select]
***** Couldn't resolve host name *****
Example 5

fails with the error message:
Code: [Select]
*********************************************
SSL peer certificate or SSH remote key was not OK
*********************************************
SSL peer certificate or SSH remote key was not OK



Example 8
runs as expected but has this error message as a message box:








See my current project on PlayStore: 20Tracks-Audio-Player https://play.google.com/store/apps/details?id=midimaster.twentytrackd

Offline Derron

  • Hero Member
  • *****
  • Posts: 3664
Re: BaH.libcurl.mod and BlitzMax NG
« Reply #1 on: February 13, 2021, 09:48:46 »
Linux also requires the installation of "libidn11-dev".



Regarding the last example:
curl.setOptInt(CURLOPT_VERBOSE, 1)

-> remove that and the error is "gone".


bye
Ron

 

SimplePortal 2.3.6 © 2008-2014, SimplePortal