October 16, 2021, 07:26:53

Author Topic: Can you use a later build of MinGW64 compiler for Blitzmax NG?  (Read 8865 times)

Offline SC-Dan37

  • Jr. Member
  • **
  • Posts: 12
Re: Can you use a later build of MinGW64 compiler for Blitzmax NG?
« Reply #30 on: August 03, 2017, 00:00:33 »
Sure Xlsior. I had found an existing issue in the bmk that seemed to fit so I commented on it. Here is the link: https://github.com/bmx-ng/bmk/issues/31. If it would be better I'll be glad to create a new issue.

Offline xlsior

  • Jr. Member
  • **
  • Posts: 33
Re: Can you use a later build of MinGW64 compiler for Blitzmax NG?
« Reply #31 on: August 03, 2017, 05:10:38 »
<...>
« Last Edit: August 03, 2017, 05:27:05 by xlsior »

Offline xlsior

  • Jr. Member
  • **
  • Posts: 33
Re: Can you use a later build of MinGW64 compiler for Blitzmax NG?
« Reply #32 on: August 03, 2017, 05:26:42 »
Duh. Nevermind, found the issue:

Your sample sticks it specifically in the 'gui build' section, and my IDE was defaulting to console instead of GUI, so it skipped the -static modification entirely.

Inserted another copy of:
Code: [Select]
If Not makelib
cmd:+" -static"
End If

at line 348, recompiled bmk, and all is working as it should, both in x86 and x64 mode -- thanks a ton for the help!

Offline SC-Dan37

  • Jr. Member
  • **
  • Posts: 12
Re: Can you use a later build of MinGW64 compiler for Blitzmax NG?
« Reply #33 on: August 03, 2017, 14:25:59 »
Wasn't sure if console would need it or not but that makes sense. Thanks for the additional info! I will update my bmk as well.

 

SimplePortal 2.3.6 © 2008-2014, SimplePortal